Home Forums Game Frame Wi-Fi Adapter Firmware 20170523 Released! Good Stuff!

This topic contains 19 replies, has 5 voices, and was last updated by Jeremy Williams Jeremy Williams 2 years, 4 months ago.

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #3746
    Jeremy Williams
    Jeremy Williams
    Keymaster

    You can download the update from GitHub:
    https://github.com/Jerware/GameFrameV2_WiFi/releases/tag/20170523

    And install it using the firmware manager:
    http://ledseq.com/manager.html

    This is a substantial update that’s been in the works for some time now. Most importantly I managed (I hope!) to fix the bug that caused Game Frame to crash and reboot when losing its Wi-Fi connection. There are also 11 NEW REAL-TIME EFFECTS in FX mode that look great. I especially like the ninth one that looks like a kaleidoscope.

    Here’s a changelog of most issues. As always, please let me know if you hit any issues.

    • System & Cloud processses now use dedicated thread
    • Wi-Fi dropout crash fix
    • 11 new effects for FX Mode
    • Lots of FX Mode-related bugs fixed
    • Firmware update triggers WIFI graphic
    • Firmware update failure visualization (red flash)
    • Network credential loss detection
    • Added network connect timeout (Game Frame will boot w/o Wi-Fi)
    • Groundwork for Alexa Skill (colors, modes, etc.)
    #3748
    Patrick
    Patrick
    Participant

    Very cool!

    #3749
    Patrick
    Patrick
    Participant

    Can I use the “command” option to change the mode from Gallery to Effects? I was trying to figure out if I used IFTTT could I send a command to flip between the modes.

    #3750
    Jeremy Williams
    Jeremy Williams
    Keymaster

    Yes, see the Advanced section of the Wi-Fi docs. To switch to effects mode, send “display 2” to the command function. Although it’s undocumented, you can also send “display effects” and that should work too (part of the pending Alexa support).

    #3751
    Patrick
    Patrick
    Participant

    I’ve been using a Google Home to do stuff but I may have to break down and get an Alexa.

    #3753
    ^MuYa^
    ^MuYa^
    Participant

    awesome!

    #3754
    boris
    boris
    Participant

    Ah, direct Alexa support sounds great – if you can also release it for German. I’m happy to provide any localization you need for this. Just contact me at my E-Mail.

    Until then I am using IFTTT to control it via Alexa. Works quite well so far.

    #3755
    boris
    boris
    Participant

    THANK YOU – great update!!!

    But: Somehow I am now back in the “old” brightness mode, where low brightness means that the “darker” colours wash out. I need to turn Brightness to at least 2/3rds so that the effects look nice – but that is REALLY bright in a darkend room.

    Did you remove that code completely?

    Boris

    #3756
    Jeremy Williams
    Jeremy Williams
    Keymaster

    Boris: That feature is disabled by default due to various reasons but you’re welcome to enable it by adding the following line to the WIFI.INI file on your microSD card inside 00system/wifi. Just make sure it appears somewhere beneath [network].

    apabright = true

    #3757
    boris
    boris
    Participant

    Jeremy: Yeah, I thought that was enabled since the last update; or did that option move or not survive the new firmware update? But it worked – the FX are fantastic. I like number three (the four dancing squares) as well as your Matrix!

    Thank you!!!

    Boris

    #3758
    Jeremy Williams
    Jeremy Williams
    Keymaster

    Boris: The previous firmware update (20161211) removed hardware brightness by default and created the option to turn it back on using the WIFI.INI entry. If you add that entry, it should work automatically with the current and future firmware releases. Does it work for you?

    #3765
    boris
    boris
    Participant

    Yeah, you enabled that and I could swear that I installed that fix and that it worked before and did not work right after the update. Well, it works now. Happy customer.

    #3794
    Andreas
    Andreas
    Participant

    Hello Jeremy,

    I have an issue with my GameFrame:

    My WiFi is disabled during the night using a time schedule. In addition I am using IFTTT to control my GameFrame power-on time.

    In detail:
    1. WiFi and GameFrame are running
    2. GameFrame is disabled using IFTTT
    3. One hour later the WiFi gets disabled
    4. In the morning, the WiFi gets enabled
    5. The GameFrame should be powered on using IFTTT again, but this step currently fails.
    I have to unplug/plug the power source to get it working again… :-/

    The IFTTT scripts are correctly working. It seems that my GameFrame hangs up during the somehow…

    Any suggestions?

    Thank you,
    Andreas

    #3795
    Jeremy Williams
    Jeremy Williams
    Keymaster

    Hi Andreas,

    If I understand correctly, once the Wi-Fi is disabled/enabled, Game Frame fails to re-connect to the Wi-Fi/Internet. Yes? You can test this by watching the LED on the Wi-Fi Adapter itself. It “breaths” cyan (light blue) when it is online.

    What firmware are you using? The latest (released in May) has some fixes for getting back online if the Wi-Fi drops.

    Jeremy

    #3796
    Andreas
    Andreas
    Participant

    Jemery, thanks for your fast help!

    After the GameFrame was disabled via IFTTT yesterday evening the light on the WiFi-Adapter remains connected (cyan “breathing”).

    As I checked the LED again this morning, it was completely off.

    I thought I updated to your latest firmware some weeks ago. The version listed in the web interface is “System version 0.6.2”. I did not found any other version string like “20170523”. Is it the correct place or is the firmware version not listed in the user interface?

    Have a nice day,
    Andreas

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.