Home Forums Game Frame General Discussion Build my own GameFrame – please help!

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #4044
    mjyaorong
    Participant

    Hi Jerware

    My name is Ring, I have micro-controller nano ATMEGA328P and ws2812b LED, SD module and clock module, but I link up and no effect,
    Can Jerware provide your sketches? If you can help me solve this problem, it will be a good, perfect, great help!

      Thank you in advance!

    Github (https://github.com/Jerware/GameFrame)

    #4047
    Jeremy WilliamsJeremy Williams
    Keymaster

    I replied to your message in the other thread. I’m afraid the source code is provided without support, but I wish you luck! With enough diligence you can definitely make it work.

    #4048
    mjyaorong
    Participant

    Hello Jeremy
      I use GameFrameV1 code, but I do not know if my link is normal, so I need your help, thanks

    #4084
    mjyaorong
    Participant

    Does Game Frame still need 00system folder? Before you can work, what is 00system folder

    #4085
    Jeremy WilliamsJeremy Williams
    Keymaster

    The 00system folder contains all of the system level graphics and data.

    #4087
    mjyaorong
    Participant

    Jeremy Williams I have enough to buy a Gamesystem SD Files with 00system, but Game Frame still doesn’t work. I use ws2812b, Atmel atmega 328 (game Frame v1)
    https://prnt.sc/iowoc4

    #4088
    mjyaorong
    Participant

    Thank you. Your order has been received.

    ORDER NUMBER:
    4086
    DATE:
    March 11, 2018
    TOTAL:
    $10.00
    PAYMENT METHOD:
    Credit Card (Stripe)

    #4089
    mjyaorong
    Participant

    Why is that

    Attachments:
    You must be logged in to view attached files.
    #4092
    Jeremy WilliamsJeremy Williams
    Keymaster

    It could be any number of things. Do you have experience debugging Arduino code? You’ll Probably need to look for other errors in that console to find out why inifile isn’t working. I assume you correctly installed the library?

    #4093
    mjyaorong
    Participant

    I made gameFrame_Clock. Now I get a new error. GameFrame doesn’t work. Only the first LED is on. The others don’t work. The following figure shows whether my connection line is correct or not. Jeremy Williams asks you to see

    https://github.com/Jerware/GameFrame/tree/master/gameFrame_Clock

    Attachments:
    You must be logged in to view attached files.
    #4098
    mjyaorong
    Participant

    This is the correct version of the 1.0.1 version, the code can be written into

    Attachments:
    You must be logged in to view attached files.
    #4100
    Jeremy WilliamsJeremy Williams
    Keymaster

    I’ve not built for the Nano but it’s very close to the Uno and you should be able to get it working. If you’re not comfortable debugging, building your own Game Frame might be a tough project! You could always go with the Teensy LC and the pre-compiled firmware.

    #4101
    mjyaorong
    Participant

    I would like to know that there is an error in the line connection in my picture? If it didn’t work, I also bought 00 system files and put it in 2G memory. Only the first LED turned on.

    #4102
    Jeremy WilliamsJeremy Williams
    Keymaster

    I’m afraid I can’t help you debug your own hardware. You need to run simple test code every step of the way to test each component. Don’t try running Game Frame code until you’re sure everything is working, and then make sure the Game Frame source is configured to the pins you need.

    #4109
    mjyaorong
    Participant

    LED does not need 6 feet

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.