Home Forums Game Frame Technical Support Remote doesn't always register Reply To: Remote doesn't always register

#2930
Christophe
Participant

I tried in a different room where there is no IR devices, and same behavior:
– on the remote test screen, when pressing NEXT I see the red and blue icons flashing at probably 1 frame each
– then the green ‘>’ icon with red border stays there until I press a button on the remote (tried waiting up to 1 minute, it waits for a valid input).
– If I press any button on the remote, the green icon+red border disappear immediately
– if I extract the SD card and read the content of remote.ini, I see: “power = 3887053538”, “menu = 2823767411”, and “next = whatever code corresponds to the button I pressed”.

Was not able to reproduce the extra “55831455” from the first attempt, though after that, the GameFrame did not reboot properly (flashing white screen, or black screen with random pixels on the left and right columns). Had to re-edit the remote.ini file to put back the original codes, and then the frame did restart properly…

Looks like the IR sensor and remote do work, but maybe the code that reads it is not clearing the buffer properly? (as in if this was code that reads from the keyboard, when you call ‘readline()’ without clearing the buffer, you would get whatever the user pressed BEFORE, which would then be read immediately…”